2021-34667 | Calendar_plugin calendar.php cross site scripting


CVSS Meta Temp Score

CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.

Current Exploit Price (≈)

Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.

CTI Interest Score

Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.

4.1 $0-$5k 0.08

A vulnerability classified as problematic has been found in Calendar_plugin up to 1.0 on WordPress (WordPress Plugin). Affected is an unknown code of the file ~/calendar.php. The manipulation of the argument $_SERVER['PHP_SELF'] with an unknown input leads to a cross site scripting vulnerability. CWE is classifying the issue as CWE-79. This is going to have an impact on integrity. An attacker might be able to inject arbitrary html and script code into the web site. This would alter the appearance and would make it possible to initiate further attacks against site visitors. CVE summarizes:

The Calendar_plugin WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to the use of `$_SERVER[‘PHP_SELF’]` in the ~/calendar.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.0.

The weakness was shared 08/17/2021. The advisory is available at wordfence.com. This vulnerability is traded as CVE-2021-34667 since 06/10/2021. The exploitability is told to be easy. It is possible to launch the attack remotely. The exploitation doesn’t require any form of authentication. Successful exploitation requires user interaction by the victim. Technical details are known, but there is no available exploit. This vulnerability is assigned to T1059.007 by the MITRE ATT&CK project.

Applying a patch is able to eliminate this problem. The bugfix is ready for download at plugins.trac.wordpress.org.

Type

Name

VulDB Meta Base Score: 4.3
VulDB Meta Temp Score: 4.1

VulDB Base Score: 4.3
VulDB Temp Score: 4.1
VulDB Vector: 🔒
VulDB Reliability: 🔍

AV AC Au C I A
🔍 🔍 🔍 🔍 🔍 🔍
🔍 🔍 🔍 🔍 🔍 🔍
🔍 🔍 🔍 🔍 🔍 🔍
Vector Complexity Authentication Confidentiality Integrity Availability
unlock unlock unlock unlock unlock unlock
unlock unlock unlock unlock unlock unlock
unlock unlock unlock unlock unlock unlock


VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Class: Cross site scripting
CWE: CWE-79
ATT&CK: T1059.007

Local: No
Remote: Yes

Availability: 🔒
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔒


0-Day unlock unlock unlock unlock
Today unlock unlock unlock unlock

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍Recommended: Patch
Status: 🔍

0-Day Time: 🔒

Patch: plugins.trac.wordpress.org

06/10/2021 CVE assigned
08/17/2021 +68 days Advisory disclosed
08/17/2021 +0 days VulDB entry created
08/19/2021 +2 days VulDB last updateAdvisory: wordfence.com
Status: Confirmed

CVE: CVE-2021-34667 (🔒)

Created: 08/17/2021 08:02
Changes: (1) source_cve_cna
Complete: 🔍

Comments

Use the official API to access entries easily!



Source link